Fun Italian Electrics! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 29-03-05 Thread Starter
Status: -
AO Member
Join Date: Feb 2003
Location: Ireland
Posts: 159
Fun Italian Electrics!

So far... the alarm button on the keyfob opens the boot..sometimes, if it works at all. More interestingly my wipers activate even when in the 'off' position.....and IIRC I didn't order any rain sensor

A bang on the dash stopped them..once, but now they're playing payback and simply won't turn off.

And the often seen Airbag light....

Last edited by Grif; 29-03-05 at 16:06.
Grif is offline  
Sponsored Links
Status: -
AO Member
tse_adam's Avatar
Join Date: Nov 2004
Location: Birmingham, UK
Posts: 989
Re: Fun Italian Electrics!

unlucky buddy....sometimes i cannot even open my boot with the fob or the button inside the car!
tse_adam is offline  
Status: -
AO Member
Join Date: Sep 2002
Location: florida
Posts: 119
Re: Fun Italian Electrics!

most electric are Kraut Bosch some made in Mayasia some in Australia,it is not all the italians fault
Bondiins is offline  
Status: -
AO Member
Join Date: Mar 2005
Posts: 146
Re: Fun Italian Electrics!

I thought I had a problem tonight,but soon realised that the Italians are brighter than me.When I put the car in reverse the rear windscreen wiper came on,I thought this strange. I took the car out of gear and it stopped,I repeated this a couple of times,then switched off the front wipers and tried the same,and hey presto it did not come on.So it is quite clever as one would need to see where you are going when reversing while it is raining.
A bit off topic I know but this had me worried for a minute or two.

try disconnecting the battery for a while as this can reset every thing
jono6974 is offline  
Status: -
AO Silver Member
Simes's Avatar
Join Date: May 2003
Location: Lancashire, UK
Posts: 1,609
Images: 10
Re: Fun Italian Electrics!

Try the wiper mechanism cleaning trick....

Basically the grease in the switch unit can mess up the connections between the wiper stalk and the circuit board...

The reccomended fix is to work the stalk quickly through the positions for a minute or so (off to full max and back)...

then see what happens

worked for mine being all intermittent......

Simes is offline  
(Post Link) post #6 of 6 Old 29-03-05 Thread Starter
Status: -
AO Member
Join Date: Feb 2003
Location: Ireland
Posts: 159
Re: Fun Italian Electrics!

heh, thanks for the tip :-)
Grif is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

electrics , fun , italian

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome