Alfa 147 Mjet Upper wishbones failed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-05-12 Thread Starter
Status: -
AO Member
Join Date: Oct 2011
Location: France
County: Brittany
Posts: 10

Member car:

Alfa 147 mjet

Alfa 147 Mjet Upper wishbones failed

Hi all. Just an interest here. Had the upper wishbones replaced in Aug last year (130k) and covered about 12k since. Just had to replace them again as the play in the bearings was bordering on dangerous. QUESTION. What is the expected mileage for a set of upper wishbones and any advice as to if I have a arguement with the fitting garage? They were genuine Alfa parts but fitted by a normal garage. Hope to hear from you - Thanks
viedelabretagne is offline  
Sponsored Links
Status: The big diesel con
AO Member
James_Bond's Avatar
Join Date: Aug 2009
Location: United Kingdom
County: Kent
Posts: 121
When you say wishbone bearings, do you mean the rubber bushes? These are the parts that normally fail first.

I would expect that sort of lifespan from a set of non-genuine items, that have been fitted dry (ie not greased first). However, genuine parts should last much longer, the ones on my car lasted 90k.

All I can guess is the parts fitted were not genuine...? Or did you supply them personally? In either case, I'm not sure the garage that fitted them are responsible for their failure, unless of course they lubricated them before fitting with something that wasn't compatible with the rubber bushes, like general purpose grease?
James_Bond is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , failed , mjet , upper , wishbones

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome