PAS Fluid ? using more than it should - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 02-05-12 Thread Starter
Status: Fiat Coupe 20v
AO Member
Bravo16v's Avatar
Join Date: Jan 2011
Location: United Kingdom
County: Lincolnshire
Posts: 214
Images: 4
PAS Fluid ? using more than it should

hey people,
ever since taking the 156 down santa pod, my PAS Fluid has been creeping below minimum level , i topped her up in march to max level, then today i had to again top it up to max level.
you cant tell me it will use this much all the time ? i haven't checked to see if the pipe is leaking or checked the pas pump just yet.

has this happened to anyone at all ?

its a 2.4 jtd if that helps
Bravo16v is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
It shouldn't use any.

So 100% you have a leak... (unless you are over-filling it and loosing excess through the breather)
David C is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

fluid , pas

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome