Selespeed problems on 2000 156 2.0ts - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Selespeed problems on 2000 156 2.0ts

Hi all, after a few years driving Mazda, I decided to switch back to a 156. This time I bought a very well looked after 156 with selespeed.

Unfortunately, after a few weeks driving it started to give some problems, first it was skipping gears, or just reving really high while changing gears. But yesterday it got a lot worse, after having these problems several times driving home, the car stalled while stopping and wouldn't turn on anymore.

The "N" woud just flash on the dashboard, while the red selespeed light would flash for a few seconds and then turn off (which is normal I think). I also noticed that when I stepped back into the car, that the buzzing noise I usually hear when opening the door wasn't there.

Then after leaving it for about 15 minutes, it just suddenly started again, only to get stuck between 3rd and 4th gear a few hundred meters down the road. The car would just rev a lot, but wouldn't change gears, even when pushing the lever. After turning it off, it wouldn't turn on again with the same problem. Again, waited for 15 minutes and it started again, leaving me to limp home in 2nd gear to avoid any gear changes that could stop me again.

I'm not quite sure about this, but it seems that the problem is worse in bad weather. I've never had any problems on sunny days, but the worst days so far have been pooring rain. Could be coincidence, but who knows.

I would appreciate any advice you could give me, before I give my life savings to an Alfa dealer.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 2000 , 20ts , problems , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome