EBD ABS system failure message - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 12-04-12 Thread Starter
Status: -
Join Date: Dec 2011
Location: Thailand
County: Chon Buri
Posts: 5

Member car:


EBD ABS system failure message

I live in Thailand far away from Alfa dealer and have had my brakes replaced by non alfa mechanic with non alfa parts. For 2 months not a problem but today after having the car washed, maybe a pressure washer was used not sure, ABS and EBD system failure message has appeared on the screen "do not use car take to dealer"
Should I worry??
jackhappy is offline  
Sponsored Links
Status: -
AO Member
Join Date: Oct 2002
Location: Croatia
Posts: 551
Looks like electrical problem or problem with battery.
First check for water inside engine bay, then check battery condition (charge or replace battery).
Boris is offline  
Status: obsessed
AO Silver Member
Loknar's Avatar
Join Date: Mar 2011
Location: Thailand
County: Bangkok
Posts: 1,407
Images: 76
Sorry to hear that bro'. It would be a short or a battery issue - if you use a water/topup battery it can happen unexpectedly.

But it is likely to be various issues with the sensors or the abs unit. If the speed sensor was not installed properly, it would be worn, or the cable destroyed (common problem when someone goes to a non-alfa shop). Need to plug in diagnostics and take it from there. I can help you or my friend p'Job at BKAutoTech but we're in Nonthaburi.

In any case, you can still drive without abs.

update: there may be a small window of opportunity when I could be convinced to go to Chonburi if we act very soon - I'm leaving the country for 2 months next monday. msg me or contact p'Job, owner of BK 0816465176 (speaks english rather well) but remember this is can't be solved on the phone!

Last edited by Loknar; 13-04-12 at 00:10.
Loknar is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

abs , ebd , failure , message , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome