Lambda Sensors / Euro3 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 11-04-12 Thread Starter
Status: -
AO Member
Dragon666's Avatar
Join Date: Sep 2008
Location: Denmark
County: Copenhagen
Posts: 24
Lambda Sensors / Euro3


Since I own a 156 MY edition with "Euro 3 Homologation" which means I have 3 Lambda Sensors (2, each at the Junction of Cyl 1,2 and 3,4) and one before the Cat.

My question is: When does the computer start to take in readings from the first two Lambda Sensors ? Normally the car will run on tablevalues until warm, but the movement of Lamba Sensors closer to the engine is designed to do proper regulation on earlier state on cold engines.

Anyone knows this ?

Thing is that the engine is running coarse on the idle, but only when cold and I have changed:

1. MAF
2. Spark Plugs
3. One defect Ign. Coil.
3. Intake valve housing.
4. Cleaned and Checked every hose from the filter to the intake valve.


Fast Forward > ZX-7R Ninja '97 > No Regrets.

Under my belt:

Alfa Romeo 155 1.8 T.S. (8 Valve) -> Crashed & Sold.
Alfa Romeo 146 1.6 Boxer -> Sold.
Dragon666 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

euro3 , lambda , sensors

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome