Turbo Lack of Power - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-04-12 Thread Starter
Status: -
Join Date: Nov 2011
Location: United Kingdom
County: -
Posts: 5

Member car:

Alfa 147

Turbo Lack of Power

Recently been experiencing issues with my boost. the turbo will kick in with no problems but sometimes normally in 2nd or 3rd it will kick in around 2k rev boost up to 3-4 K then drops back down to 2.5k with no increase in power. In the high gears 5 or 6 there never seems to be any boost.

When using the cruise control to speed up if the turbo kicks in once the boost drops out it kicks the car out of cruise.

This has been happing for a couple of months and finally having a chance to service the car yesterday i asked the mechanic to check out the lack of power and he told me the turbo is losing pressure and is failing but i choose not to believe this as there seems to be no other signs of a turbo failure.

On another note i only get smoke when i accelerate hard and the boost kicks in but not always the case.
gavynalfa is offline  
Sponsored Links
AO Gold Member
davealfa11's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Merseyside
Posts: 9,904
Images: 4

Member car:

156 1.9 mjet 16v

check your intercooler pipes for leaks
check small bore pipe from turbo actuator to solenoid valve and to engine .perished or fine holes or splits
take egr valve off and clean it with carb cleaner and also map sensor on inlet manifold
davealfa11 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

failure , lack , power , powerboost , turbo , turbo problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome