156 battery draining overnight - Page 3 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Silver Member
Oliver_K's Avatar
Join Date: Jan 2007
Location: United Kingdom
County: Surrey
Posts: 1,581
Its a funny coincidence I posted on this thread. Car was dead on Saturday. The RAC Bosch battery is just over a year old. Tried my jump starter buy i think that needs replacing too. Called the RAC. The batt was giving 12 volts once he had it started but it wasnt accepting charge properly. Replaced FOC, no quibble. Fantastic guy even put a jubillee clip around my MAF for me as it was loose.

Just a note on battery drain.... when he tested for a drain on the batt there was a drain untill he locked the car on the button and waited about 2 mins for a big click from somewhere then down to a nominal reading. So if anybody is testing for a drain be patient.
Oliver_K is offline  
Sponsored Links
Status: -
AO Silver Member
Dickymint_156's Avatar
Join Date: Mar 2011
Location: United Kingdom
County: Somerset
Posts: 1,116
Images: 4
well never started the car saturday so went out to start it on sunday and it turned over realy fast and started instantly so touch wood rewiring the Alpine and using the right oil did its job! also its amazing how much better the sounds its so much quieter and smoother when you start it! it was just a pity it took 3 hours to change the frikkin oil!
Dickymint_156 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , battery , draining , overnight

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome