I need help!! just had a diag, read below u'll be amazed - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: Aching hand from all the waxing !
AO Member
MrsNewt1's Avatar
Join Date: Jan 2010
Location: United Kingdom
County: North Yorkshire
Posts: 134
The problem is....if you 'get rid'...next week some blokes going to be on here asking exactly the same questions. You're now obligated to point out the faults when selling which means you'll get nowt for it.
MrsNewt1 is offline  
Sponsored Links
Status: ooh,an extra gear!!
AO Member
Join Date: Aug 2011
Posts: 382
with bodged wiring in the engine loom,is it possible some of these errors and the limp mode is being caused by a blown fuse?i only mention it because my jtd had a long list of errors and permanent limp mode and would have cost the best part of 500 to fix,IF the errors were caused by the parts being indicated.the parts were all ok,(with one or two exceptions),the cause was a blown fuse,in the auxiliary fuse box,up by the steering wheel/dashboard.elearn and the owners handbook said the fuse only protected the airbags . . . it also supplied power to the egr,afm,glow plug relay,boost solenoid.it took a while studying the wiring diagram on elearn,but i figured it out eventually,after checking all the engine wiring loom was ok . . . . .
sorry if this has already been checked,but i thought i'd mention it,anyway.
Maximum respect for Ned,i've read a few posts relating to autolusso and have been very impressed with the way they deal with their customers.good old fashioned customer service!
Looneymoo is offline  
Status: - Update
Posts: n/a

Most i'd do would be check the battery and the loom for bad connections , the two big plugs between the intake + the bulkhead and unbodge the 'repairs' , beyond that why not use it to repair another one or just replace it , come on fella driving an alfa that only spin's to 3k it just seem's wrong , they need driving ;-)
, Nee .

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

amazed , diag , read , ull

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome