sat nav unit on the blink.147 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 25-03-12 Thread Starter
Status: sterio still on glitch
G.ONEILL147's Avatar
Join Date: Mar 2012
Location: United Kingdom
County: Kent
Posts: 8

Member car:

alfa 147 2.0

sat nav unit on the blink.147

147 built in sat nav on the blink
hello everyone,
wandering if anyone could give me some advice. ive got a 2001 model 147, with the built in sat nav unit (the one that controls the radio/sat nav/ trip computer etc)

Sat nav is on the blink. when i start the car, the alfa logo comes on, and then it seems to crash and try and restart again. it just keeps doing this. so it wont boot up, the radio and sat nav wont work.

has anyone come accross this before?

any help or advice? ive seen some posts on another site about a weak battery causing other electrical faults. is this likely?

thanks in advance for any help
G.ONEILL147 is offline  
Sponsored Links
Status: -
Join Date: Aug 2012
County: -
Posts: 1

Member car:


147 Sat Nav Unit is also on the blink!

Hello everyone,

First timer here. I've also got the same problem happening now with my 147 sat nav unit - it's exactly as described on this thread topic! Did you manage to resolve the problem? Appreciate any insight and advice. Thanks in advance for any help.
ALF72 is offline  
Status: Thinking about giulia veloce
Club Member
Membro Premio
jwq's Avatar
Club Member Number: 857
Join Date: Jan 2005
Location: The Netherlands
County: Zuid Holland
Posts: 4,103
Images: 16
Could be a problem with the power supply of the connect.....
Could also be a firmware problem. You could try reflashing the system software, however, there is always a risk that it goes wrong....
jwq is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

blink147 , nav , sat , unit

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome