MCSF Light keep coming on and consumes alot of oil - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-03-12 Thread Starter
Status: -
Join Date: Feb 2012
Location: Norway
County: Hordaland
Posts: 5
MCSF Light keep coming on and consumes alot of oil

My 02, 2.0 Selespeed 147 is being a ***** again... i had som small leaks in the exhaust which my workshop said was causing the failure and said it was the lambda sensor, now i have spent a ton of money replacing the whole exhaust, but the light still comes on. i lose power over 3500RPM.... also, the car drinks alot of oil, it has consumed 2,5 litres in 5 months, have checked for leaks and the only thing i can see is that the oil pan is sweating a little bit, but not enough to consume 2.5 litres of oil.

please help.... im tired of my baby being sick. and the workshops seems to not know what they are doing...
147Selespeed02 is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
Originally Posted by 147Selespeed02 View Post has consumed 2,5 litres in 5 months...
How many miles/km in that time?
David C is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alot , coming , consumes , light , mcsf , oil

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome