alfa 147 jtdm black smoke after cam belt snapping please help - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 17-03-12 Thread Starter
Status: -
AO Member
itacarboy's Avatar
Join Date: Oct 2007
Location: United Kingdom
County: Herefordshire
Posts: 869
Help alfa 147 jtdm black smoke after cam belt snapping please help

hi guys long time since i posted on here.

iv found a 147 jtdm 120k pretty cheap to buy but......

the cam belt had snapped along with a couple rockers that snapped also.

its been put back together by a mechanic apparently..

and its had a new injector and since this work has been done its smokes black smoke,

and when you rev it it misfires? took it for a spin down the road seems to boost well but the smoke is pretty obvious

I'm really shocked that its not bent one of the valves and to snap a rocker it must have had a couple valves hit the piston.

soo question is.... is a valve not seating very well hence the over fuel or is it possible that its just another injector needed?

any opinions welcome


TAKE REVENGE!!!, Sh*t On A Pigeon
itacarboy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , belt , black , cam , jtdm , smoke , snapping

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome