Water and oil - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 14-03-12 Thread Starter
Status: -
Join Date: Mar 2012
Location: United Kingdom
County: South Yorkshire
Posts: 1

Member car:

147 2.0 TS

Water and oil

Hi there first time post so forgive me if I miss any obvious information out. I have a 2004 147 2.0 TS. I have noticed over the last few weeks that my water and oil levels seem to drop quite often but there is no obvious sign of a leak or anything, is this a common problem or is it something I need to have a garage look at??? Thanks in advance Chris
Chrisanders83 is offline  
Sponsored Links
Status: -
AO Silver Member
gil_147's Avatar
Join Date: Oct 2005
Location: United Kingdom
County: Tyne and Wear
Posts: 1,634
Images: 11
The Alfa TS engines are rather fond of oil. No leaks typically, they just consume it. Keep a regular eye on your oil level, i.e. every week until you get used to how much your car is using, then adjust as you feel comfortable. When I had a 2.0TS I was probably topping up/checking every couple of weeks (pushed to remember I would say I was topping up 1/4ltr every 1000miles - but one engine to the next will vary). The difference between the max and min on your dipstick equates to around 1ltr and this should be kept topped up to max at all times.

No experience to comment on water/coolant loss i'm afraid.
gil_147 is offline  
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,991
Loosing coolant is not normal and needs looking at ASAP before it suddenly lets go and wrecks the engine.

FYI coolant isn't just water, so I hope you haven't just been filling it with water...?
David C is online now  
Status: - Update
Posts: n/a
err... my first suspect would be hose or a pinhole in rad (esspecially if old) is it looseing all the copper fins?

trouble is you probs won't see leak until it is hot so get car hot then sit idleing till fans cut in. then you should see if small leak somewhere.

also check pass side carpet in footwell towards middle in case leak is in interior cabin matrix.

if your using red coolant any leak will eventually build up to a whitey pink ressidue around leak area. not sure if blue stuff leaves as obvious a sign.

Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,285
Images: 12
blue leaves a light coloured residue ...
gazza82 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

oil , water

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome