GT JTS Engine Whine - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-03-12 Thread Starter
Status: -
Join Date: Mar 2012
Location: United Kingdom
County: West Sussex
Posts: 6

Member car:

Alfa GT

GT JTS Engine Whine

Hi all,

I've recently purchased a 2004 GT 2.0JTS with only 29,000 miles on the clock. The service history is comprehensive and it underwent a cambelt change with a specialist about 7,000 miles ago. The problem is that the engine is producing a shrill whining noise when starting from cold between around 800-1500rpm. The problem is pretty much eliminated by the time the engine is up to temperature.

A brief conversation with a local mechanic (without him looking at it) presented the idea that the tensioner may not be working with as much strength as it used to and that this noise could be remedied by putting chalk on the belt, but this was more effort than it was worth.

Any ideas/information would be greatly appreciated.

MikeGT101 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jan 2009
Location: United Kingdom
County: Glasgow
Posts: 243

Member car:

156 2005 2.0 jts

Mine does that and it has done for a while. Needs the belt and extras done this summer though, not through mileage but 3 years gone since the last. The noise from mine though disappears after about 30secs not 2-3 miles! It also appears worse when its been raining heavily but this may be in my head. The rain thing kinda makes me think its the fan belt but i aint no machanic......i guess i'll find out when it gets done this may/june
Hope you get it sorted.............
zorander is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , jts , whine

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome