156 V6 24v - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 25-02-05 Thread Starter
Status: -
AO Member
Join Date: Feb 2005
Location: Benfleet, Essex
Posts: 37

Member car:

Guilia Super

Hmmm 156 V6 24v

I have had the cam belt changed and the engine serviced. Since then the engine runs really rough, does not want to idle and is a pig to start sometimes.On the go there is a coughing and what sounds like a backfire when the throttle is depressed. It only limps along at the moment.
The garage has rechecked the cam timing,ok, all the connections,ok, and no fault codes are present. They are at a bit of a fix. Does anyone have an idea or direction to help them.
They said they will check the compression and sparking next as a matter of doing/checking things...
Spudulike1 is offline  
Sponsored Links
Status: -
AO Member
paulmcd's Avatar
Join Date: Apr 2003
Location: Dublin, Ireland
Posts: 93

Member car:

156 2.5 V6

Re: 156 V6 24v

coil packs? I think these are removed or at least wiring disturbed during the cambelt swap? Also the specialist I use told me the cam pulleys are simply a taper fit (not keyed) onto the cams and that they come slightly loose with time, going slightly out wrt each other. One of mine had done so slightly.
paulmcd is offline  
Status: -
AO Member
daveg360's Avatar
Join Date: Jun 2004
Posts: 511
Re: 156 V6 24v

I reckon the garage haven't done the timing correctly. Did they use locking tools? If they didn't they need some actual skill and attention to detail. This is absent in most garages (especially dealers )
daveg360 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 24v

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome