Ideas please Dumped oil after head / cambelt refit - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 02-03-12 Thread Starter
Status: -
AO Member
Join Date: Jan 2012
Location: United Kingdom
County: Suffolk
Posts: 10

Member car:

2.0 147 TS Lusso

Ideas please Dumped oil after head / cambelt refit

Having just completed a head rebuild due to cambelt failure and 16 bent Valves, today I started it up, Started perfectly and run fine but seemed to take a while for oil to get up and quiten down. I checked after about 30 seconds that the oil light was not on as I went back round the front I saw it had dumped all the oil on the floor, seems to be from around oil filter cooler but sp peed off that I shut garage up and will have better look Tommorow. I am aware that the bottom end shells could be damaged and may be cause of low pressure but why or how can it dump the oil. Just a fairly capable home mechanic, no manual so dont know the internal layout of 2.0 eng but can oil pump get damaged in this situation. Any suggestion or thoughts welcome
donnyjepp is offline  
Sponsored Links
Status: - Update
Posts: n/a
the heat exchanger could be punctured or perhaps the oil fitler was loose?

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

cambelt , dumped , head , ideas , oil , refit

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome