Pas pipe snap connector different?? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 28-02-12 Thread Starter
Status: -
Join Date: Feb 2012
Location: United Kingdom
County: -
Posts: 2
Pas pipe snap connector different??

Please I need urgent reliable advice! Thank you ALFA 156 16v JTD 1.9 54 plate

Having put up with a small corroded hole in my low pressure PS aluminium pipe (right next to the holding bracket), I have finally reluctantly purchased new PS pipes as a pair for 160 all in inc VAT & delivery.

However the old pipe where it attaches to the PS radiator pipes at the front, uses a kind of fast snap connector with 4 triggers or catches around the shell of the connector which you have to press all of them in to release the pipe you want to change. This leaves a grey plastic ring of the 4 trigger catches you just had to press in to release the pipe. Fine so far!

The new PAS pipe is plastic coated to avoid corrosion, great! but the snap connector to push back onto the PAS radiator pipe is a bit different, it has only two grey triggers to push in to release, it is a bit different.

Question? Does anyone know if this is ok & the two different connections are compatible? If so will I have the same problem on the snap in connector at the reservoir end?

gregjames67 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

connector , pas , pipe , snap

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome