147 1.9JTD EGR valve or turbo? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 26-02-12 Thread Starter
Status: -
Join Date: Oct 2011
Location: United Kingdom
County: Derbyshire
Posts: 4

Member car:

147 1.9JTD

147 1.9JTD EGR valve or turbo?

Hi all,

I've been having some problems with my car which, from a bit of research on here I think could well be down to the EGR valve. I also found a guide to replacing it but before I go down that path I wanted to be sure it was this.

My symptoms are an occasional loss of power where I can't pick up any more revs unless I put the clutch in and spin up the revs (and turbo) and then feed it back in, sometimes with an accompanying cloud of smoke. Also on some, but not all, start ups the idle is really lumpy and struggles to pick up, also with big clouds of smoke.

This started just after having the master cylinder replaced, could something have been knocked or damaged which would trigger this?

Is there any test I can do to show whether it is the EGR valve rather than a turbo or other issue?

Thanks for your assistance.
Battimus is offline  
Sponsored Links
Status: - Update
Posts: n/a
it could be a split in the hose from the turbo to the Inter-Cooler [ short pipe approx 2 foot long ] or from the Inter-Cooler to the engine [ approx 3.5 foot long ]

also check the small vacuum hose to the turbo actuator as they often perish.

& of course don't forget to try disconnecting the MAF sensor, if the car runs better then replace the MAF sensor.
AO Gold Member
davealfa11's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Merseyside
Posts: 9,904
Images: 4

Member car:

156 1.9 mjet 16v

clean egr and map and see how it goes
davealfa11 is offline  
Status: turbo charger assembler
AO Silver Member
Join Date: Nov 2010
Location: United Kingdom
County: West Yorkshire
Posts: 1,928
not turbo, the only smoke u will see via that is blue smoke as it burns oil........
black smoke and bogging down is egr dont just clean it.......make sure the pin on solenoid moves ! and do map sensor as well.......just to left of egr on rear of engine.....one torx bit holds it in
carb cleaner to clean it.......not wd40
hdseven is offline  
Status: -
AO Member
mark_wildman86's Avatar
Join Date: May 2011
Location: United Kingdom
County: Staffordshire
Posts: 87
I did mine on Sat an can say for how long it takes it is the best thing to try- Dead easy to perform, A couple of the bolts on the lower part of the EGR can be a pig but once its off, Clean, Re Clean and Clean again-

When you take apart the EGR valve the small pin is meant to pop out approx 1/2inch or so- Its not clear on the guide how far it comes out so....

Made a huge difference to low end grunt an almost elimated the cloud of smoke I used to kick out under hard acceleration- It was that bad I felt like I was in wacky racers at times!!

Good luck
mark_wildman86 is offline  
(Post Link) post #6 of 6 Old 27-02-12 Thread Starter
Status: -
Join Date: Oct 2011
Location: United Kingdom
County: Derbyshire
Posts: 4

Member car:

147 1.9JTD

Thanks for all the help guys.

When it comes to checking the hoses am I better doing that from under the car, not sure of the routings but they sound like they might be slightly more hidden away.
Battimus is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , 19jtd , egr , jtd , turbo , valve

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome