Koni str - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 19-02-12 Thread Starter
Status: 20v
AO Member
Join Date: Jun 2007
Location: United Kingdom
County: Argyll and Bute
Posts: 406
Images: 10

Member car:

alfa GT JTDm

Koni str

Any one tried koni str shocks with original springs on a 2.4 jtd
surfwagon is offline  
Sponsored Links
Status: Nurburgring here we come!
AO Member
goremohekan's Avatar
Join Date: Sep 2012
Location: United Kingdom
County: Kent
Posts: 918
Originally Posted by surfwagon View Post
Any one tried koni str shocks with original springs on a 2.4 jtd
Hi, I had massive problems with these as the Konis are different from the Alfa original. Whatever the combination of reaming out the original Alfa top mount bush sleeve (yes the Koni piston top fitting is wider diameter than the original) and then using the top hat bush (or not)supplied to lock in the cir-clip....I had problems with the top end of the piston riding up through the top mounts..
After a second attempt to refit by my usually competent mechanic I then took the car (with new Alfa genuine top mount bushes) to an Alfa specialist. By this time the top hat bushes, if they ever existed were long gone... but the Alfa guy didn't want to go drilling out the new top mounts, so we reverted to new Alfa original dampers....

I'm now in a conversation with Larkspeed as to whether koni really expect fitters to ream out and modify existing mounting points on the car in order to fit their products....

any one else used these STR.ts and had problems with fitting?
goremohekan is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

koni , str

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome