Disconnecting glow plugs on 1.9 multijet - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 17-02-12 Thread Starter
Status: -
Join Date: May 2006
Location: United Kingdom
County: Tyne and Wear
Posts: 8

Member car:

156 lusso m-jet

Disconnecting glow plugs on 1.9 multijet

I'm trying to check the resistance of the glow plugs after the dreaded 30-second flashing on cold mornings, but stuck at how to disconnect the wire? I must be a total thickie as I can't find out anything on the subject. Is it just a case of pulling hard, away from the plug? I don't want to break the connector but I've tried pulling, pushing, turning, and cannot get the darn thing off.

For each of the four glow plugs, the feed wire goes into a plastic surround, about 3 inches long. This narrows down to the other endwhen it grips the top of the glow plug. The whole plastic surround will turn, but it's not unscrewing. Do I have to get that plastic off first to expose the connector?

Any help appreciated!
adey is offline  
Sponsored Links
Status: I'm here where are you?
AO Member
xanman7's Avatar
Join Date: Aug 2008
Location: Evesham
Posts: 52
Not sure if its the same on a multijet but on my 8v JTD the plastic shroud is L shaped so I just looped some wire under the plastic and pulled straight up and they pop off.

They do feel as if they are about to break before coming away though.

The other option is to disconnect the multi plug from the Bulk Head relay just behing the EGR and meter the values from here as it make the job a lot simpler.

Again this info is based on a 03 plate 8v JTD

Good Luck
xanman7 is offline  
(Post Link) post #3 of 5 Old 17-02-12 Thread Starter
Status: -
Join Date: May 2006
Location: United Kingdom
County: Tyne and Wear
Posts: 8

Member car:

156 lusso m-jet

They aren't L-shaped on mine, they are straight, pencil-like. But perhaps it is just a case of a strong pull - I just feel as if the force required will break something! I've already broken the plastic tabs off the headlamp cover, since no amount of gentle persuasion made any progress. Brute force then did the damage .. afterwards, it's always easy to see how you should pull/twist/pinch etc, but first time, it's a voyage into the unknown
adey is offline  
Status: Enjoying a nice mug of tea
AO Silver Member
Join Date: Oct 2008
Location: United Kingdom
County: Bedfordshire
Posts: 1,752
They should pull off - very similar connection to a spark plug, if they have not been off for a while there may be some corrosion adding to the tightness
CJO is offline  
Status: -
AO Member
Daytona's Avatar
Join Date: Jun 2006
Location: United Kingdom
County: Greater London
Posts: 744
Mine are straight also - just need a firm tug to pop off....I wouldn't particularly worry about checking the resistance etc. Just take out the plugs...the faulty one(s) will be black and sooty.

I had the same problem and replacing the sooty plug cured it.
Daytona is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

disconnecting , glow , multijet , plugs

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome