2001 156 2.0 Selespeed Problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 10-02-12 Thread Starter
Status: -
Join Date: Feb 2012
Location: Turkey
County: Izmir
Posts: 1
2001 156 2.0 Selespeed Problem

Hello, Im sure, the same problems discussed a lot of time on that forum. But, i wanted to open new thread anyway. so,

My problem is, my 2001 alfa romeo 156 Selespeed, only 59k miles and there is a transmission problem. When i turn on the ignition before the starting, selespeed warning light on. When i start and when i driving, it's all time on.. And i cant get the 3th gear. Only first and second gears work.. We changed the transmission oil before, But nothing is change.

If i change the transmission ECU, it will be FIX? or DO i have to Change the CLUTCH.
ALFAROMEO156TR is offline  
Sponsored Links
Status: skint!
AO Silver Member
cannotstop's Avatar
Join Date: Aug 2009
Location: Ireland
County: Dublin
Posts: 1,197

Member car:

156 GTA & 156 Ti

Not likely. It seems your clutch works, as you are able to clutch in and out.

What you have to to do is get AlfaDiag, and connect a laptop to the car. Only then will you know what the problem is. Could be as simple as a recalibration is needed, or a sensor that needs replacing.

But you wont know until you connect the car up to AlfaDiag or FiatECUscan.
cannotstop is offline  
Status: -
AO Member
Join Date: Jul 2011
Location: United Kingdom
County: Shropshire
Posts: 13
Images: 2
hi,i am having a very similar problem.i have hooked up to alfadiag and its come up with code P0720,which according to the code list is a speed sensor.the other think that has happened to my 156 ss is thespeedo has stopped working completely but the rev counter still works.does anyone know if they may be connected?
pauljaq156 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 2001 , problem , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome