hellppppppppppppppp Pls! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 09-02-12 Thread Starter
Status: maybe a Golf..but the funs in an Alfa!
iamaskaman's Avatar
Join Date: Oct 2011
Location: United Kingdom
County: West Midlands
Posts: 4

Member car:


hellppppppppppppppp Pls!

my beloved 156 1.8 t-spark has decided to present me with a problem....

when the engine is cold it looses power in acceleration at low revs and as they pick up, backfires!..

i have read many a post about MAF and sensor, which i followed, by removing and carefully cleaning as stated... then moved on and checked my spark plugs, there was a splash of oils in the one nearest the oil cap, this i put down to me bit shakey handed on the oil fill up, i put back the spark plugs in a different order !....

Result... it was WORSE!!!

Now it severly looses power at low revs to the point the revs drop to near the engine cutting out.. pulling away from stand still is a nighmare.

any ideas or advice pls??????
iamaskaman is offline  
Sponsored Links
Status: faclifting a 156
AO Silver Member
biffa's Avatar
Join Date: Oct 2006
Location: United Kingdom
County: Lancashire
Posts: 3,199
Images: 9
Your maf was dying but cleaning it has now killed it, to drivng the car with it unplugged it might not idle very well but it should run better if its your MAF.
biffa is offline  
Status: working hard
AO Member
Chris Cousins's Avatar
Join Date: May 2003
County: -
Posts: 811
Images: 38
Had a backfiring problem on my 2001 156 V6 18 months or so ago. I changed the MAF but the fault code was still present; it was traced to the wire that connects the MAF to the ECU which had rubbed through on the bulkhead due to a missing grommet. This caused a short which blew some fuses.

Only other thing I can suggest is new plugs and coil packs.....
Chris Cousins is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

hellppppppppppppppp , pls

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome