Selespeed crunch and missing gears - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 08-02-12 Thread Starter
Status: -
Join Date: Feb 2012
Location: United Kingdom
County: Cheshire
Posts: 1

Member car:

156 Veloce

Selespeed crunch and missing gears

Hi, I've got a 156 Sportwagon Veloce and the selespeed box has started to crunch slightly in 3rd and 4th. The other issue (slightly more important) is the car has started to miss gears. It can be fine for a week or so and then it will skip from 2nd to neutral, no warning lights come on the dashboard, then when you push the gearstick it will go straight into 5th it will behave again the next day. I've changed the relay for the 'box with no difference. I can't find any info' on the web which gives the same symptoms. Can anyone help please?
stellagod is offline  
Sponsored Links
Status: -
Join Date: Feb 2012
Location: United Kingdom
County: West Yorkshire
Posts: 5

Member car:


i would check clutch rod length first,you can do this with a multimeter between green wire (poss pin 7) and earth with key at mar and adjust rod length to 3.7 volts and retry
jezza1 is offline  
Status: Alfa nut
AO Silver Member
Join Date: Dec 2011
Location: United Kingdom
County: East Sussex
Posts: 1,271
Or get fiatecuscan check the clutch pushrod length and do a fault check.Remember its a normal clutch with a release bearing so the clutch could be showing signs of age its not always the fault of the actuator.
jim hazell is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

crunch , gears , missing , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome