147 Smoking Issues... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 04-02-12 Thread Starter
Status: Now just the 147..
AO Silver Member
lovelyred159's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Somerset
Posts: 1,949
Images: 11

Member car:

147 1.6 Lusso

147 Smoking Issues...

The wife's 2003 147 has been laid up for the last three weeks as we were mid house-move so I went to it on Monday as it was still on the original battery.
Needless to say would not start, all the lights came on, the starter sluggishly turned but then the battery died.
Left it on charge for 2 days on trickle, put it back in and got the engine reluctantly started.
Almost immeadiately a "low battery charge" warning came up on the info screen and as I revved the engine, there was a slight squeek then smoke started to pour out the bonnet.
Quickly switched off and after recovery a seized alternator was diagnosed and will need a new battery and drive belt too.
The car has been recovered to Red Motori near Blandford Forum as they are my nearest indy now, anyone used them and do they have a good rep?
lovelyred159 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , issues , smoking

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome