156 2.0L T.Spark 'Pinking' Noise Exhaust - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 03-02-12 Thread Starter
Status: Still trying to find that Noise...
AO Member
Chris_gta's Avatar
Join Date: Jun 2011
Location: United Kingdom
County: Essex
Posts: 920
156 2.0L T.Spark 'Pinking' Noise Exhaust

last September my flexi section of the exhaust went, replaced with a Bosal aftermarket as Bosal is good quality steel and welding on the exhausts.

since the replacement of this exhaust section, i am getting a metallic 'pinking' noise at 2100RPM
seems as though something is resonating at this RPM (above and below this RPM i cant hear it)

but when fault finding, i came across a broken exhaust manifold bracket (attached to the engine block to the manifold) this is hidden behind the manifold btw.

the bracket had a hairline crack all the way across it and i thought that it was this that was the problem. but since removing this it is still doing it.

But...i am aware that new exhaust sections need a layer of carbon before that metallic noise goes away.

but i have read on other forums that other people are having the same problem and noise!

any suggestions would be great, thanks for reading.

Chris_gta is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 20l , exhaust , noise , pinking , tspark

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome