147 Selespeed System Failiure. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 03-02-12 Thread Starter
Status: -
Join Date: Feb 2012
Location: South Africa
County: Gauteng
Posts: 1
Hmmm 147 Selespeed System Failiure.

Hi, my 147 Selespeed recently went for a pump service, however when it came back I noticed that whenever I got to the 5th gear the 5 would flash and the transmission oil was leaking. i then took the car back to the mechanic who said it needed to be recalibrated and he did, but then soon after that it keeps on saying Selespeed system failuire, locks the gears and shows the ember engen sign. i have to stop the car and restart then i can drive for a while before it starts again. the machenic did diagnostics and there was no fault found. please help.

.....and if you know another place where i can take it which won't cost alot but does quality work on selespeed in Gauteng please do advice aswel.

Last edited by CzweM; 03-02-12 at 09:57.
CzweM is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,995
Originally Posted by CzweM View Post
...and the transmission oil was leaking.
Gear oil or Selespeed fluid?
David C is offline  
Status: Gold Member
AO Gold Member
rarebear's Avatar
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,021
do you know the pressure of the sele system ? should be 50-55 bar and stable...
rarebear is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , failiure , selespeed , selespeed system failure , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome