147 Drove me crazy !!! help - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-01-12 Thread Starter
Status: -
Join Date: Jan 2012
Location: Greece
County: Attica
Posts: 1

Member car:


Madness 147 Drove me crazy !!! help

Hello every one

Well there is many things that i have to ask about any idea will help me to make my baby 147 back to normal

Well lets go on

1 : ) i have to problem with the head lights , when i opened the cover of the head lights i round a burned cables for the normal head light not the high beam i was tracking the fuses and they were doing gr8 nothing burned but i found out when i turn on the lights and i turn on the high beam to see the small light turns off on the left side light !! there is a short some where but i donno where is it yet !

2: ) the screen that shows u the mileage keeps on blinking !!!

3: ) some times under 2500 Rpm my car makes sound like bubbling and it doesn't have power i feel am driving a V8 alfa romeo loooool but it really weird !!!!

4: ) the steering keeps on pulling on the right side i check the air PSI and it was okay (2.2-2.5) actually when it was 2.2 it was making it more than when it was 2.5 so i went to a guy that check the steering down here in greece and he told me there is nothing wrong !!! but i really feel it doing this thing aaaa by the way over 140 KM/H the steering starts shaking a lil bit

thanks for any help in advance

Guys dont get me down pls i love this car and i want to make it run like new :'(
147 lover is offline  
Sponsored Links
Status: -
AO Member
Join Date: Oct 2011
Location: United Kingdom
County: Kent
Posts: 276

Member car:

147 2.0

I think I can help with no.2, the flashing seems to be your Canbus system detecting something wrong i.e you've removed or replaced an electrical component & you'll get the mileage flashing.

No.4, tracking?
Newcard is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , crazy , drove

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome