Electrical Gremlins help please. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 21-01-12 Thread Starter
Status: -
AO Member
Join Date: Apr 2010
Location: New Zealand
County: -
Posts: 77
Help Electrical Gremlins help please.

Hi All

2000 156 V6 Manual,

I have electrical gremlins that are causing more than bearable grief.

The boot warning light is staying on even though the boot is closed.
I see there are two push buttons either side of the latch that still spring fine.
I have made sure both switches are down but still the light stays on.

does there need to be contact with the boot to complete the circuit? whats the best process for isolating the problem.

Subsequent to this the central locking does not stay locked, I assume because the car thinks the boot is still open.

The other problem, is that the speedo drops when the head lights are on and the indicators are used.
I read on the forum that this is normally a bad earth, but have cleaned the terminals and I still get the problem.


Much appreciated any help you can offer. Cheers.
hendrik789 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

electrical , gremlins

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome