Selespeed actuator - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-01-12 Thread Starter
Status: dodging potholes in Beirut...
AO Member
Join Date: Nov 2011
Location: Lebanon
County: -
Posts: 18

Member car:

Alfa Romeo 156

Selespeed actuator

Apart from the bunny hopping, my car developed a new symptom today. As I was driving uphills, the Selespeed buzzer and in-dash indicator came on. Running on 5th gear, I tried to kick the gear down to come to a stop. However, 4th didn't engage and it jumped to N.
I parked on the side of the road to start pondering what the deal is - I turned the engine off. I kinda hoped that by turning it off and on again, the fault would magically clear. The car wouldn't turn on. Tried changing gears on MAR, then kicked it back into N. The car started back up as if nothing ever happened - well, not exactly, as it intermittently switches to N while driving every now and then.
I rang my mechanic, he has a few used actuators that he stripped down from scrap cars he imports from Europe. He charges $400 USD including labor and a two-month warranty for a used actuator.

What do you guys think?

2000 Alfa Romeo 156 2.0 Selespeed / Cosmo blue
DanR. is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jun 2010
Location: United Kingdom
County: Surrey
Posts: 444

Member car:

147 selespeed

if it solves the problem then that seems ok to me
antman147 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

actuator , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome