156 odd noises :( - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 16-01-12 Thread Starter
Status: So much on my mind :(
AO Member
Join Date: Jan 2012
Location: United Kingdom
County: Staffordshire
Posts: 64
Help 156 odd noises :(

Hi all

Hope someone an help me with this

Just bought my first Alfa last week and it's now started to make some odd noises ....

Every time I go over a speed bump (slowly of course) the whole car seems to creak I think this could be shocks or suspension but it's happening at the front and rear and the front headed top arms for the mot.

Also the front off side (drivers side) wheel makes an occasional rubbing sound, any ideas?

I'm hoping this car isn't going to be a trip into very light pockets for mechanical work already

Principal DJ & Owner
Christopher David Entertainment

To Do : Oil & Filter Change, New clock cluster (bulb problems), Boot Catch (I got to use wiper as a handle to open), Install reversing sensors
PipeDreams : CarPC, Bose speaker upgrade, Rear electric window install
Completed : Stereo Upgrade
Richardstarkie is offline  
Sponsored Links
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
It will be either uper or lower wishbone. Lower tends to rattle. Upper tends to creak. Easy job which shouldn't take very long . If you use the search function you'll see it has been brought up many times
Joss is offline  
Status: kerbed alloy, oh b***ocks
AO Member
Adam147's Avatar
Join Date: Feb 2010
Location: United Kingdom
County: West Midlands
Posts: 149
Images: 10
Could also be the anti roll bar bushes creaking front and rear
Adam147 is offline  
(Post Link) post #4 of 4 Old 20-01-12 Thread Starter
Status: So much on my mind :(
AO Member
Join Date: Jan 2012
Location: United Kingdom
County: Staffordshire
Posts: 64
Ok oddness happening :s

All of a sudden yesterday the creaking stopped from the front end and the back end creaks that I thought I heard I think we're just the front re-settling

Could it have been the new top arms wearing / settling in?
Richardstarkie is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , noises , odd

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome