Car dies when aircon turned on - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 13-01-12 Thread Starter
Status: -
Join Date: Aug 2011
Location: Australia
County: New South Wales
Posts: 2
Help Car dies when aircon turned on

I am trying to find an answer to our problem.
A few weeks ago I was driving with the aircon on and all of a sudden there was a loud crunching noise and car did not drive very well at all and selespeed error comes up on dash. Turned aircon off and car drives great. Now every time I turn the aircon on the car dies.

Any help would be much appreciated.

ace34t is offline  
Sponsored Links
Status: -
AO Member
gammakeith's Avatar
Join Date: Nov 2010
Location: United Kingdom
County: Nottinghamshire
Posts: 817

Member car:

156 JTD 2.4 20V

At a guess the air con clutch has started to disintegrate. The extra drag on the engine is pulling the tickover down which is causing the selespeed error?

gammakeith is offline  
Status: -
AO Silver Member
TOX1C's Avatar
Join Date: Aug 2004
Location: Amesbury
County: Wiltshire
Posts: 4,325
Images: 9
My air con clutch is very noisy when switched on, and is even getting noisy when it's not on! When it's on the belt seems to be jumping around so it seems to be the clutch; it almost sounds like there is a stone in the pulley.
TOX1C is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

aircon , car , dies , turned

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome