Alfa 147 all warning lights - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 12-01-12 Thread Starter
Status: -
Join Date: Jan 2012
Location: United Kingdom
County: Cornwall
Posts: 4
Looky Looky Alfa 147 all warning lights

Hi All i need some advice with my Alfa,

Sometimes when i start my Alfa all the warning lights appear (not including engine management).
When i put my foot down the engine management light appears & the car has no acceleration/power.
Does anyone here have an answer to this issue!


panos68 is offline  
Sponsored Links
Status: - Update
Posts: n/a
yes, you need to get the car diagnosed...... could be all down to a single bad earth connnection.
Status: -
AO Member
Join Date: Jul 2005
Location: Brizzle!
Posts: 74
buy a new battery - your life will change!
paulos is offline  
Status: Back in V6-land!
AO Silver Member
Ronald's Avatar
Join Date: Jul 2006
Location: United Kingdom
County: Kent
Posts: 3,336
Images: 30

Member car:

Not an Alfa

Originally Posted by paulos View Post
buy a new battery - your life will change!
Ronald is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , lights , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome