Squeaking Clutch Pedal - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 10-01-12 Thread Starter
Status: -
AO Member
Join Date: Jan 2010
Location: Ireland
County: Dublin
Posts: 95

Member car:

08 147 Monza

Squeaking Clutch Pedal


Have a really annoying squeaking issue with my clutch pedal in my 147. Can't seem to locate where its coming from.

Any ideas where to start on locating it? Sounds like a creaking floor board in a horror movie...
glumsden is offline  
Sponsored Links
Status: -
AO Silver Member
amfalconer's Avatar
Join Date: Aug 2011
Location: United Kingdom
County: Hampshire
Posts: 1,351
Images: 10

Member car:

147 1.6TS

There's plenty of posts on here complete with pictures of the part in question.

The clutch master cylinder acts directly on the pedal, if you drop the fusebox cover under the steering wheel, you will see a rubber bush and pushrod at the far left at the top of the clutch pedal.

Numerous people have quietned theirs with the aid of spray grease on the push rod and under the little rubber boot.

I had this issue on mine, and it didn't help at all, I had to replace the master cylinder shortly afterwards which stopped the squeak, not sure whether lubricating this contributed to the failure of the master cylinder or not
amfalconer is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

clutch , pedal , squeaking

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome