My 156 revs up to 2500 and down continuously by itself on idle speed! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 08-01-12 Thread Starter
Status: -
Join Date: Apr 2010
Location: Norway
County: -
Posts: 7
My 156 revs up to 2500 and down continuously by itself on idle speed!


I got a big problem that not even the local Alfa Romeo garage can help me with. The car revs up to 2500rpm and down to 1000 continuously after it has gotten warm standing still. The rpm is normal after I start the car cold. It maybe revs up 250 rpm like someone is hitting the choke right after start, but i quess that is normal.
As i said when the car gets warm, it starts reving itself.

I have tried to clean the "air divider" after the air flow measurer on the intakehose. Could not find any problems there..

Anybody got any heads up for this? Im kinda getting desperate here..

And excuse my english, im norwegian

Raakky is offline  
Sponsored Links
Status: - Update
Posts: n/a
I know of a '00 selespeed that had that issue on it too. After alot of testing, resetting etc it turned out the Engine ECU needed replacing.

Thing is if you are buying a 2nd hand ecu you'll need the immobiliser code box, & key [ transponder chip ] too.

If you need a set drop me a PM.
Status: - Update
Posts: n/a
on the 'oo S/speed all engine sensors were changed before coming to the conclusion that the ECU must be the issue. A manual Engine ECU 'set' was fitted & the idle was perfect, fitting back the S/speed ecu 'set' the issue returned. Trust me 2 days of time was spent chasing this issue, not to mention half a tank of petrol

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 2500 , continuously , idle , revs , speed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome