Why blank the EGR? - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Silver Member
Join Date: Jul 2012
Location: United Kingdom
County: Cambridgeshire
Posts: 1,146
Well I have the om four hole blank on my 156 .

I added the one that is diamond shape yesterday and in traffic tonight it threw the mcsf low volume via egr fault!!

Cleared it and will see how it goes
swampy76 is offline  
Sponsored Links
Status: Alfaless
AO Member
Alfa Seltzer's Avatar
Join Date: May 2011
Location: United Kingdom
County: Hants
Posts: 948

Member car:

GT...Golf GT

1.9 JTD here with both plates fitted and no problems.

There are two versions of the diamond plate available, with either 1 or 3 holes present.
The 1 hole version can cause the light to come on as it apparently does not allow enough flow through the valve.
Alfa Seltzer is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

blank , egr

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome