Windscreens washer not squirting - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 15-12-11 Thread Starter
Status: -
Join Date: Oct 2011
Location: United Kingdom
County: Essex
Posts: 3

Member car:


Windscreens washer not squirting

Hi, my windscreen washers are not working, when I pull the stick to give the windscreen a squirt nothing comes out and I can hear no noise either. I take it that if the nozzles were blocked I'd at least hear the motor? Seeing as I can hear nothing I assume that either the motor has died or the fuse has blown. Does anyone know where the windscreen washer fuse is located, and where the actual motor is located as well. Any other ideas welcome!
knappster is offline  
Sponsored Links
Status: DEFCON5
AO Gold Member
1of1's Avatar
Join Date: Oct 2010
Location: Sao Tome and Principe
County: Principe
Posts: 11,605
Images: 7
Dunno which fuse sorry, but the motor should be audible & is located on the side of the washer bottle, I had to replace mine a while back, sourced one from a local motor factor (meant for a ford IIRC, but was a perfect match)
1of1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

squirting , washer , windcreen , windscreens

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome