p0340 on jtd - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 14-12-11 Thread Starter
Status: love to get hold of the guy who invented the egr
AO Member
Join Date: Jul 2010
Location: United Kingdom
County: Leicestershire
Posts: 41
p0340 on jtd

Hi all,
after the dreaded go to dealer message appeared and the engine `hunting` below 1250rpm
got a p0340 error code up on my 04 jtd m-jet. off the diag i get camshaft position error , low signal . ive read that the sensor can be cleaned at one end , but where is it on the jtds ? if the sensor is had it does the belt have to changed when the sensor is changed ,car had belt change 10k ago. finally what price am i looking at for sensor change? cheers
p47 is offline  
Sponsored Links
Status: 1750TBIecusoftware.. done!.40+bhp
Join Date: Jan 2009
Location: United Kingdom
County: Merseyside
Posts: 3,480
Images: 10

Member car:

various Alfas

Check that the belt hasn't slipped.
ALFA TUNER is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

jtd , p0340

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome