156 JTS : tricky MCSF - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 07-12-11 Thread Starter
Status: -
Join Date: Mar 2010
Location: Singapore
County: -
Posts: 2

Member car:

156 JTS

156 JTS : tricky MCSF

Hi guys,
I need some advice.
Basically I went through the similar path of various MCSF problems related to mis-firing.
Finally manage to eliminate the problems by replacing all 4 injectors 2 months ago.

However, 2 days ago the MCSF flashes again with loss of power for 5s.
After that, car back to normal.
The check engine light reset after 3~5 restart.

Checked with FES, P0267-cyl 3 injector with signal low is stored.
Apart from injector failure, any idea what could be other potential rootcause?
Any recommendation for next steps? I did clean the connector with contact cleaner.

156_yk is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , jts , mcsf , tricky

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome