Universal Lambda sensors? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 04-12-11 Thread Starter
Status: -
AO Member
Join Date: Apr 2010
Location: I would rather not say
County: -
Posts: 129

Member car:


Hmmm Universal Lambda sensors?

Was wondering if anyone on here has had any success will universal lambda sensors? My car needs three at 60 each which is quite expensive compared to 30 each for universal type. My car is a 147 1.6 tspark.. Any experiences or commets on the universal type greatfully appreciated...
mattys147 is offline  
Sponsored Links
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,288
Images: 12
My 156 was fitted with an NTK Lamdba for a few years. The original failed to pass the MOT and in a hurry, I had what the garage could get hold of at the time and quickly.

... and it was a constant nightmare as it consistently threw up errors, sometimes forcing the engine management light to come on. Turns out that their sensors are a different ohm rating to Bosch. The ECU didn't like that and was assuming it was a problem. It's highly likely that other "universal" lambdas will be the same and in the end a waste of money.

To save a few pounds, I fitted a BOSCH universal (LS615) which means you have to cut the original cable (not just anywhere!!!), and fit a simple screw-in wiring block. No soldering or any clever stuff, just the ability to cut it in the right place and strip the ends of the wires a few mm up. Then twist and fit. The cable is held in to place with screw in fittings that you just need to tighten with your fingers.


After fitting the new Bosch I also realised my fuel consumption was much better.

A lot of cars use the same sensor ... the difference is in the plug at the end and the length of cable. It's highly likely the 1.6 is the same as my TS except I only have one to worry about

cheers, Gary

HIS: 1998 156 2.0 TSpark with Sport Pack 2, sunroof and hi-level spoiler in Alfa Rosso. V6 intake mod, clear side repeaters and Zeatek undertray.

HERS: 2009 MiTo 1.4 95bhp Turismo arrived 21st November in Techno Grey with colour-coded headlight surrounds.

"If you're driving on the edge ... you're leaving too much room!"
My Alfa156 Web Site - how-to's, piccies, links, useful stuff, etc.
gazza82 is offline  
Status: - Update
Posts: n/a
life will be much more enjoyable if you only use BOSCH Lambdas , end of....

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

lambda , sensors , universal

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome