156 indicators - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 02-12-11 Thread Starter
Status: 147 jtd 1.9. super car.....
AO Member
fala 4 bolts's Avatar
Join Date: Oct 2009
Location: United Kingdom
County: Stirling
Posts: 220
Images: 10

Member car:

147 jtd lusso

156 indicators

my indicators come on left and right but do not flash ie they stay lit all the time
help d.s...................
fala 4 bolts is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
The flasher unit is on the back of the stalk switch unit.
David C is offline  
Status: - Update
Posts: n/a
remove the bottom cowling to gain access, 3 X headed screws. the blue relay can come out withot removing the stalk, check thats its not just loose.
Status: - Update
Posts: n/a
Never try the above method, actually, because one of the contact for the relay is on top of the plastic and it gets bend easily, can be broken even easier. One that is broken....

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , indicators

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome