147 Clutch - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 17-11-11 Thread Starter
Status: -
AO Member
Join Date: May 2011
Location: United Kingdom
County: West Midlands
Posts: 10

Member car:

Alfa 147

147 Clutch


I dont know if this is normal for 147's but the clutch on mine seems very high. It is also very hard to drive smooth at low speeds and changing from 1st to 2nd is not smooth at all.

Is this a sign of the clutch is about to go? The car has recently passed a MOT less than a month ago so i thought any issues would have been picked up.

Is there anyway you can adjust the bite point on the clutch?
Seamonkey45 is offline  
Sponsored Links
AO Gold Member
davealfa11's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Merseyside
Posts: 9,904
Images: 4

Member car:

156 1.9 mjet 16v

new clutch looks in order and clutch not part of MOT
davealfa11 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , clutch

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome