Suspension Problem. help needed! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Wave Suspension Problem. help needed!

I've recently had the springs and dampers replaced on my 147. Its cover 67k miles. I also had the top ball joints replaced. The car handles better than it did but still you can really feel any little bumps in the road. This is accompanied but a dull thudding sound. there is also a small creaking sound as i come to a stop. Any ideas where I could look next to resolve this?
Sponsored Links
Status: - Update
Posts: n/a
Re: Suspension Problem. help needed!

Maybe with all that new kit it was worth doing the lower wishbones too as a matter of routine? I'm doing this very soon myself, a Rhoddy Harvey-Bailey kit, new springs and dampers, and also new upper and lower wishbones. The stuff is all in my shed, waiting for the friendly Italian brother-of-girlfriend to fit!

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

needed , problem , suspension

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome