Trouble Trouble :-( - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-10-11 Thread Starter
Status: My first Alfa :-) and loving it
AO Member
Join Date: Sep 2010
Location: United Kingdom
County: Flintshire
Posts: 41
Help Trouble Trouble :-(

Hi All,
Just stopped to put petrol in my 156 t spark, switched engine off put petrol in, jumped back in started car up NO dash lights, started raining and window was half open, went to close it and guess what WONT go up please someone tell me its a fuse? No dash lights but headlights work and window wont close ??????????????????? cant have much more bad luck in the last 12 months had new engine new gear box new air flow mass meter etc etc etc etc etc etc and now this love my car to bits but its getting a bit like my wife, bloody sexy and lovely to drive ............but a pain in the arse

Cheers all, hope someone can help
1st alfa 156 is offline  
Sponsored Links
Status: Chillin
AO Silver Member
Chocoboy's Avatar
Join Date: Dec 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 5,621
Images: 13

Member car:

2005 147 JTD

sorry can't be much help other than to assume like you a fuse blown??
Chocoboy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome