Crank sensor? Glow plugs? Want to buy my 156?! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 24-10-11 Thread Starter
Status: battling with VDC system failure....
AO Member
Chimpy's Avatar
Join Date: Mar 2011
Location: United Kingdom
County: Warwickshire
Posts: 13

Member car:


Cry Like A Baby Crank sensor? Glow plugs? Want to buy my 156?!

So, 7 months into Alfa ownership - an extra 1400 on top of purchase price already.

Alternator and DMS and Clutch.....

Newest problem - most mornings/times the **** has been sat for a few hours and cooled down, the glow plug warning light doesn't come on. Turning the key repeatedly for about 5 minutes seems to bring it on, at which point it sometimes starts, or sometimes just turns over.

Do this a few times and it fires - glow plug light flashes for a little bit, and then it's fine. I can then stop a few times, etc, but as soon as i leave him for more than a couple of hours, same procedure over and over again.

Getting pretty annoying now - i've been reading this may be the crank sensor - but no-one seems to have had the same symptoms as mine so wanted to double check!

Any ideas?


Chimpy is offline  
Sponsored Links
Status: -
AO Member
alid1's Avatar
Join Date: Mar 2006
Location: United Kingdom
County: West Midlands
Posts: 656
Images: 5

Member car:

Alfa 147 JTDm

Not the crank sensor...sounds like your glow plugs are faulty or the glow plug relay might be at fault. It could also be the glowplug control unit.

I would start with the relay first.
alid1 is offline  
Status: Injected with a poison
AO Member
satanism's Avatar
Join Date: Sep 2008
Location: Denmark
County: Fyn
Posts: 970
Images: 10
well i'd say that one is pretty obvious.Get the plugs and glow systems checked and replace them(all, regardless if any of the sparks are still OK)...for a common rail engine not to start after it cools down, it means that you've got quite a few out.If it was crank sensor, in my experience, it will start making problems starting when the car is hot at first...
and you shouldn't get annoyed at them...glow plugs are consumables, same as brake pads don't get angry at the car when your pads wear out and you can't stop do you?

2004 156SW 2.4JTD M-Jet 20V
Currently: 189Whp@3850rpm / 410Nm@2400rpm

EX 1999 146 1.6TS 16V
satanism is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , buy , crank , glow , plugs , sensor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome