Air cond prob - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 02-12-04 Thread Starter
Status: -
AO Member
thkc's Avatar
Join Date: Jun 2004
Location: Singapore
County: -
Posts: 24
Air cond prob

I have a 147 Selespeed and the two center aircond blowers seems to be giving some problems. The one on the right seems to be warmer than the one on the left. At 22C, the one on the left is cold but the right one has a tinge of warmth. But at 24C the one on the right blows warm air while the left is still cold... ???? Does anyone have this problem? Have taken the car in many times to check but they don't seem to be able to identify what is the cause of the problem... They just say that this is "normal"

In fact when I got my car, the air cond was working great. After sending it in for service, kaput!
thkc is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

air , cond , prob

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome