Motor Control Sensor Failure advise please - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 16-10-11 Thread Starter
Status: -
Join Date: Sep 2011
Location: United Kingdom
County: Wiltshire
Posts: 3

Member car:


Motor Control Sensor Failure advise please

Hi there

I have just purchased from a dealer my first ever Alfa, a 147 TS Collezione 2007, with 60,000miles on the clock. I think its fantastic and is the best car I have ever owned, but the other day I had the dreaded MCSF come up on the dash, and then went off leaving the engine management light permanently displayed. The car seemed to drive fine, but I had my local garage read off the fault codes, the results are, P0139 O2 sensor signal after CAT (slow), P0420 catalyst converter, P0136 O2 sensor signal after CAT, P0130 O2 sensor 1 signal before CAT, P0150 sensor 2 signal before CAT. The garage cleared the faults off (2 days ago) and then today on a 200 mile drive,the MCSF display has come back, The car seems to drive fine, although I think it may be using a little too much fuel. Any thought before I contact the dealer?
wobwalsh64 is offline  
Sponsored Links
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,073
The problem is that the faults previously logged may well have been historic, and certainly must have been transient, as once cleared off, they didn't immediately recur. Most of them seem to be related to lambda sensor issues, so I'd reckon its worth checking the wiring and particularly the connectors for the lambda sensors - especially the two front ones, coming from the pre-cats in the downpipes.

But of course as you say you recently purchased the car, I reckon the first recourse should be to the dealer you got it from - its his responsibility to provide a car of "merchantable quality"......

AROC Vice-Chairman and Lancashire Section Secretary

Alfa organ donor to the gentry......
rgwm is offline  
Status: Back in the game
AO Member
Lebowski's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Antrim
Posts: 512
Images: 7

Member car:


Even if you got no official warranty with the car, the dealer has to supply a minimum 3 month warranty by law - you would be surprised how may people do not realise this.
Lebowski is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

advise , control , failure , motor , sensor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome