147 JTD 16V vibration while accelerating... help - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 10-10-11 Thread Starter
Status: -
Join Date: Aug 2011
Location: Sweden
County: Västra Götaland
Posts: 2
Images: 12
Hmmm 147 JTD 16V vibration while accelerating... help

It's vibrating while accelerating, and wibration goes away while driving evenly. When i bought it vibration was very bad, so i did change number of parts already (like WISHBONE ARM LOWER AND UPPER & LINKS). Have changed inner parts of driveshaft on both sides also. Vibratioon decreased dramaticly, but it's still there. So what i think is that i need to change the other part of driveshaft also, but problem is that i don't know where to get part number so i could seek out where to order new one for a good price (since it's rare model and it's impossible too get used one and it's way to expensive at a dealer). And i really hope that it's not a common problem on this model?

MetalTATTOO is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , 16v , accelerating , jtd , vibration

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome