GT Demist - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 01-10-11 Thread Starter
Status: dent free Lusso and lovin it:D
Club Member
Membro Premio
Fast Frank's Avatar
Club Member Number: 96
Join Date: Apr 2006
Location: United Kingdom
County: North Lanarkshire
Posts: 13,135

Member car:

GT Lusso 2.0 JTS

GT Demist

My demist is driving me up the wall. When it's switched on the heater goes to full temp and full power to the fan. I can adjust the fan, but not the temp, which seems a bit round the wrong way. Am I doing something wrong, missing something?

Thanks in anticipation
FF the sweaty blob
Fast Frank is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jul 2011
Location: United Kingdom
County: West Lothian
Posts: 12

Member car:


Mines is the same mate. Just assumed that this was the norm!
cmorrison6 is offline  
Status: the wife can't wrestle but you should see her box
AO Silver Member
PANIC's Avatar
Join Date: Jan 2009
Location: United Kingdom
County: Durham
Posts: 2,053
same here. when hot I normally just crack a window open
PANIC is offline  
Status: 99.9% Sorted.
AO Member
19frost59's Avatar
Join Date: Feb 2011
Location: United Kingdom
County: Derbyshire
Posts: 360

Member car:

156 Veloce

And mine and the aircon comes on as well.
19frost59 is offline  
Graham P
Status: - Update
Posts: n/a
Ha ha one thing I do not miss about the GT. A nightmare to clear the frost in the winter too (and open the doors )

There's a lot I do miss though
Status: -
AO Member
JetSetJim's Avatar
Join Date: Aug 2007
Location: United Kingdom
County: Surrey
Posts: 309
Images: 22
Are you talking about the front or rear window demist button? The front is supposed to do that, it's the demist mode.
JetSetJim is offline  
Status: Red
Registered User
Join Date: Jan 2010
Location: United Kingdom
County: Denbighshire
Posts: 173

Member car:


I get the same on the 147 - generally, I end up with the demister on and the windows down even in the dead of winter - this is one thing that irritates me, especially as it is easy to solve - ford have a 'built in to the windscreen' system and this works really well. Not sure why no- one else has adopted that system....
7re43d2 is offline  
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
Originally Posted by nickmoff View Post have a 'built in to the windscreen' system and this works really well. Not sure why no- one else has adopted that system....
Because they would have to pay Ford to use it...
David C is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome