heads up on running out of fuel - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Member
kickstart68's Avatar
Join Date: Dec 2008
Location: United Kingdom
County: Staffordshire
Posts: 929

Member car:

Alfa 33

Originally Posted by Grahameo View Post
Oh , and...... Please read the OP AGAIN... regarding that the FUEL GUAGE was showing ABOVE the RED!...... NOT EMPTY OR ANYWHERE NEAR IT... I also may add that the yellow warning light wasn't on either! HARDLY "RUNNING ON FUMES"!
Bit of a nasty one that, with virtually no warning. Years ago on a 75 TS we landed up with the fuel gauge showing plenty but running out of fuel, having just fitted a new tank. The fuel pump pickup was sitting high in the tank.

Originally Posted by Grahameo View Post
It never ceases to amaze me... If fuel going into the tank was that dirty..... Don't you think that there would be the slightest of possibilities that fuel station pump filters and breathers would have clogged a long time before now?
Had it on a carbed 33. Very fine sand in the fuel. I installed a filter (wasn't one as standard) which was almost blocked with this sand in about 4000 miles. But nothing similar before or since.

All the best

kickstart68 is offline  
Sponsored Links

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

fuel , heads , running

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome