Fault code P0404 on 147 JTD - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-09-11 Thread Starter
Status: sooo not missing my MX-3 :-D
AO Member
DeeJayB's Avatar
Join Date: Aug 2011
Location: United Kingdom
County: Derbyshire
Posts: 34
Fault code P0404 on 147 JTD

Hi all
I've done some searching but I'm still not entirely sure what's the cause of fault code P0404.
Am I right to assume that this is probably a problem with the EGR solenoid/actuator, and that I should either clean or perhaps replace? I've seen the list of codes posted, but I honestly don't know enough yet to really understand it.

If it makes a difference the car is a 147 1.9 JTD 8V, 2003

DeeJayB is offline  
Sponsored Links
AO Gold Member
davealfa11's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Merseyside
Posts: 9,904
Images: 4

Member car:

156 1.9 mjet 16v

strip EGR clean it out plus gas or carb cleaner and check intake tube not blocked
davealfa11 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , code , fault , jtd , p0404

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome